routeprotocol.com

Lab: Configuring Simple LISP

LISP turns traditional routing upside down.

Instead of routes being pushed to all over to other router in the network, routers now request a central server on how and where to access a certain route, almost like a computer querying a DNS server with a domain name for an IP address.

The topology for this lab

The goal in this lab is to establish connectivity between Branch-A (192.168.1.1) and Branch-B (192.168.2.1) without any of the Core-X devices knowing anything about 192.168.0.0/16

This means between LISP1 and LISP2 packets should be encapsulated within another UDP frame, being dissembled or assembled once they reach LISP1 or LISP2.

LISP3 will be the Map Resolver and Map Server in this topology, it will let Branch-A know how to reach Branch-B’s 192.168.2.0 network

Core-A

version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Core-A
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
clock timezone GMT 0 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef    
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
cts logging verbose
!
!
!
redundancy
!
!
! 
!
!
!
!
!         
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 10.0.2.2 255.255.255.0
 ip ospf 1 area 0
!
interface Ethernet0/1
 ip address 10.0.3.2 255.255.255.0
 ip ospf 1 area 0
!
interface Ethernet0/2
 ip address 10.0.1.1 255.255.255.0
 ip ospf 1 area 0
!
interface Ethernet0/3
 no ip address
 shutdown
!         
router ospf 1
 default-information originate metric 1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 Null0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input none
!
!
end

Core-B

version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Core-B
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
bsd-client server url https://cloudsso.cisco.com/as/token.oauth2
clock timezone GMT 0 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef    
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
cts logging verbose
!
!
!
redundancy
!
!
! 
!
!
!
!
!         
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 10.0.1.2 255.255.255.0
 ip ospf 1 area 0
!
interface Ethernet0/1
 ip address 10.0.0.1 255.255.255.0
 ip ospf 1 area 0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!         
router ospf 1
 passive-interface default
 no passive-interface Ethernet0/0
 no passive-interface Ethernet0/1
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!         
line con 0
 logging synchronous
line aux 0
line vty 0 4
 login
 transport input none
!
!
end

Branch A

version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Branch-A
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone GMT 0 0
!
!
!
!         
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
! 
!
!
!
!
!
!
!
!         
!
!
!
!
interface Ethernet0/0
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
ip default-gateway 192.168.1.254
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.1.254
!         
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Branch B

version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Branch-B
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone GMT 0 0
!
!
!
!         
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
! 
!
!
!
!
!
!
!
!         
!
!
!
!
interface Ethernet0/0
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Vlan1
 ip address 192.168.2.1 255.255.255.0
!
ip default-gateway 192.168.2.254
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.2.254
!         
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

Branch C

version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Branch-C
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone GMT 0 0
!
!
!
!         
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
! 
!
!
!
!
!
!
!
!         
!
!
!
!
interface Ethernet0/0
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Vlan1
 ip address 192.168.3.1 255.255.255.0
!
ip default-gateway 192.168.3.254
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 192.168.3.254
!         
!
!
!
!
control-plane
!
!
line con 0
 logging synchronous
line aux 0
line vty 0 4
!
!
end

LISP1

version 17.3
service timestamps debug datetime msec
service timestamps log datetime msec
! Call-home is enabled by Smart-Licensing.
service call-home
platform qfp utilization monitor load 80
platform punt-keepalive disable-kernel-core
platform console serial
!
hostname LISP1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!         
!
!
!
!
!
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
! 
! 
! 
! 
!
!         
multilink bundle-name authenticated
!
!
site-manager
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-2035463266
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2035463266
 revocation-check none
 rsakeypair TP-self-signed-2035463266
!         
crypto pki trustpoint SLA-TrustPoint
 enrollment pkcs12
 revocation-check crl
!
!
crypto pki certificate chain TP-self-signed-2035463266
 certificate self-signed 01
  30820330 30820218 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 32303335 34363332 3636301E 170D3231 31303130 31363337 
  30335A17 0D333131 30313031 36333730 335A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 30333534 
  36333236 36308201 22300D06 092A8648 86F70D01 01010500 0382010F 00308201 
  0A028201 0100A6F1 31F3927D 9F3B7EB0 9302859C 80BB6A1F C1F5808B 752FC5DD 
  613ABC83 9F92F397 E7B3D8C8 2C743B47 C11E80BA C378ACC2 E40FB8B2 2BD13BFA 
  B389D314 7436897D D1DC79E7 47DDB4F6 5EDD4487 27EAB93D 8E7D55DF 7B742103 
  F19F441B D4BF7512 CD74668B CD4F704E 05142CF6 18B3CCE1 8113BE3A 18F5C06E 
  9368AC4C E5C14182 68618C44 2437270C 82357403 6A913437 83D85E59 452D5094 
  31415EE2 A2538C2B B3E754CE F3BADCCF AD3739C8 0BE24F26 ADF7DB9A A058199D 
  75D7C93A 9F839A68 A78C584D FE7F8C34 5A294FE8 53FC459F 2B440F74 C9D1A953 
  BE446592 EE17C752 85CCC0BA B757ABD3 D9A6D054 7A8E04B4 A9BD39B7 0CC6C100 
  CC22D49B 4AAB0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 
  301F0603 551D2304 18301680 14F17BA8 02DDDA46 D7F98977 87B1BB48 7EF49CA6 
  84301D06 03551D0E 04160414 F17BA802 DDDA46D7 F9897787 B1BB487E F49CA684 
  300D0609 2A864886 F70D0101 05050003 82010100 968AFCCA 3E655823 3530EF7C 
  357AFC1D 2C607F6E 1BE914C3 B67E3E12 CEAB44BC FFE571C3 0FCF3940 470A288F 
  29241DB5 C366EDF2 6CECF6AF 47149388 5F446B15 3B74C3F1 EA90504E 63C7B366 
  A3AA3C1F D192648A 795D1863 93A001F9 3F95B318 8824850A 24619305 DFC8F6B9 
  110C0E70 48CC6C2D 86DF5C65 83007962 F7DC2DE9 892A5B6C E113814F 1A3CED14 
  5DD20BAB 6AEA9C35 15DBCED3 B9D69B7F FF1A2D78 EA9E30C4 712863A2 61D5989C 
  0357D07B DD73B1CE 2218998E 5DCC0EE0 E998C523 AA218063 FC3AE0CE 5CF8C252 
  52AC13D3 4F79DB2E DA762DB8 380C174B 0A64E7F5 E4825B60 7DE8874D 85B2FE7A 
  56705E07 B624B55D 5A407583 83E11BC7 33216902
  quit
crypto pki certificate chain SLA-TrustPoint
 certificate ca 01
  30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030 
  32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363 
  6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934 
  3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305 
  43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720 
  526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030 
  82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D 
  CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520 
  1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE 
  4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC 
  7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188 
  68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7 
  C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191 
  C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44 
  DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201 
  06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85 
  4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500 
  03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905 
  604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B 
  D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8 
  467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C 
  7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B 
  5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678 
  80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB 
  418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0 
  D697DF7F 28
  quit
!
license udi pid CSR1000V sn 9P5KOJYS125
diagnostic bootup level minimal
memory free low-watermark processor 71507
!
!         
spanning-tree extend system-id
!
!
redundancy
!
!
!
!
!
!
!
! 
!
!
!
!
!
!
!
!
!
!
!         
!
!
! 
! 
!
!
interface Loopback1
 ip address 192.168.100.1 255.255.255.255
!
interface LISP0
!
interface GigabitEthernet1
 ip address 10.0.0.2 255.255.255.0
 ip ospf 1 area 0
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet2
 ip address 192.168.1.254 255.255.255.0
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet3
 no ip address
 shutdown
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet4
 no ip address
 shutdown
 negotiation auto
 no mop enabled
 no mop sysid
!
router lisp
 locator-table default
 locator-set LISP1
  10.0.0.2 priority 10 weight 10
  exit-locator-set
 !
 service ipv4
  itr map-resolver 10.0.3.1
  itr
  etr map-server 10.0.3.1 key cisco
  etr
  exit-service-ipv4
 !
 instance-id 0
  service ipv4
   eid-table default
   database-mapping 192.168.1.0/24 locator-set LISP1
   database-mapping 192.168.100.1/32 locator-set LISP1
   exit-service-ipv4
  !
  exit-instance-id
 !
 loc-reach-algorithm rloc-probing
 exit-router-lisp
!
router ospf 1
 passive-interface default
 no passive-interface GigabitEthernet1
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
line con 0
 stopbits 1
line vty 0 4
 login
 transport input ssh
!         
call-home
 ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
 ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
 contact-email-addr sch-smart-licensing@cisco.com
 profile "CiscoTAC-1"
  active
  destination transport-method http
!
!
!
!
!
end

LISP2

version 17.3
service timestamps debug datetime msec
service timestamps log datetime msec
! Call-home is enabled by Smart-Licensing.
service call-home
platform qfp utilization monitor load 80
platform punt-keepalive disable-kernel-core
platform console serial
!
hostname LISP2
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!         
!
!
!
!
!
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
! 
! 
! 
! 
!
!         
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-1261116406
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1261116406
 revocation-check none
 rsakeypair TP-self-signed-1261116406
!
crypto pki trustpoint SLA-TrustPoint
 enrollment pkcs12
 revocation-check crl
!
!
crypto pki certificate chain TP-self-signed-1261116406
 certificate self-signed 01
  30820330 30820218 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 31323631 31313634 3036301E 170D3231 31303130 31363336 
  33395A17 0D333131 30313031 36333633 395A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32363131 
  31363430 36308201 22300D06 092A8648 86F70D01 01010500 0382010F 00308201 
  0A028201 0100A35E D9B5A6EE 658AFD0D CB2C33F5 3AD6416F E2B62DCF 0E062D29 
  C26780C8 C721F7BD 09C8CEAE 34777B93 3D32D2FA 8790ECF5 03F103F3 21FBA7A9 
  DDDFDF12 8ADDF4C0 68A5F9AB 17CAD94B 1607F5B0 8B44AE01 14235D48 4FCE6D4B 
  FD7AC641 39270D56 53C234A7 DE39C2F2 5319AB5D 658F8F69 4C83A19D A774F59D 
  BCC6A2C6 C4764455 3470395C AD2EBCB6 0672AAD0 2CF77955 A50FC051 5DF28BE9 
  0B631415 9DBD3261 0C1AEAFA 7D3D01CC 48CCEDC2 0D7F0E54 7B765D3D 2C5EAA76 
  ADB36331 80DFC7E3 E0CCA52E A5DB06B2 DA3881D5 1D7EAC5B FB0884F7 EF5BF474 
  BD5E6078 C56F3CFD A64659E2 1AC9A4F2 A504F012 56C6261B 1CC63613 052F52A0 
  B92DA76F C85D0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 
  301F0603 551D2304 18301680 14519F25 068BB5F6 07E7C465 BF6B05AF 7BAFE374 
  33301D06 03551D0E 04160414 519F2506 8BB5F607 E7C465BF 6B05AF7B AFE37433 
  300D0609 2A864886 F70D0101 05050003 82010100 5FE8C44B 6D3A999A A4A003D1 
  D53657F9 B916B63A EB5E5DC1 CBCD43E9 F743BE63 F4187110 E95A1E79 62446FFB 
  F81A19DE E0FF6D1F DCAEA103 F78702A1 71E26618 44E6EA03 8DC071A7 9108C661 
  BF41CCFC 3FF05BC1 5E1E6D00 CE560997 BCB89668 D150AE25 9828AA22 D1430630 
  300DBE4F E17C5FE4 72209835 AF179A5B 401F6FE0 AC485EC4 BCAE5839 333E960B 
  79A404F9 FC33F81C 46E685AB 755ACC5C 226456D7 0B9EC1DD 8A9DA36D 408EF5CD 
  CC5A994C A5DD65AE 84BFE14B B205AA37 810A2623 FFBD5A8D 72199926 3F5078D4 
  44733B94 E6ACCCDE F6407B2D 572E26AF 0D7B5A2C 06C6E860 15E7ED7E EB0949B7 
  EE89D43F 477E256C 8C615010 5F3872B7 EF07816A
  quit
crypto pki certificate chain SLA-TrustPoint
 certificate ca 01
  30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030 
  32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363 
  6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934 
  3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305 
  43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720 
  526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030 
  82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D 
  CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520 
  1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE 
  4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC 
  7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188 
  68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7 
  C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191 
  C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44 
  DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201 
  06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85 
  4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500 
  03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905 
  604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B 
  D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8 
  467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C 
  7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B 
  5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678 
  80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB 
  418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0 
  D697DF7F 28
  quit
!
license udi pid CSR1000V sn 92ON2VPD1AD
diagnostic bootup level minimal
memory free low-watermark processor 71507
!
!
spanning-tree extend system-id
!
!
redundancy
!
!
!
!
!
!
!
! 
!
!
!
!
!
!
!
!
!
!
!
!         
!
! 
! 
!
!
interface Loopback1
 ip address 192.168.100.2 255.255.255.255
!
interface LISP0
!
interface GigabitEthernet1
 ip address 10.0.2.1 255.255.255.0
 ip ospf 1 area 0
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet2
 ip address 192.168.2.254 255.255.255.0
 negotiation auto
 no mop enabled
 no mop sysid
!         
interface GigabitEthernet3
 no ip address
 shutdown
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet4
 no ip address
 shutdown
 negotiation auto
 no mop enabled
 no mop sysid
!
router lisp
 locator-table default
 locator-set LISP2
  10.0.2.1 priority 10 weight 10
  exit-locator-set
 !
 service ipv4
  itr map-resolver 10.0.3.1
  itr     
  etr map-server 10.0.3.1 key cisco
  etr
  exit-service-ipv4
 !
 instance-id 0
  service ipv4
   eid-table default
   database-mapping 192.168.2.0/24 locator-set LISP2
   database-mapping 192.168.100.2/32 locator-set LISP2
   exit-service-ipv4
  !
  exit-instance-id
 !
 loc-reach-algorithm rloc-probing
 exit-router-lisp
!
router ospf 1
 passive-interface default
 no passive-interface GigabitEthernet1
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
line con 0
 stopbits 1
line vty 0 4
 login
 transport input ssh
!
call-home 
 ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
 ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
 contact-email-addr sch-smart-licensing@cisco.com
 profile "CiscoTAC-1"
  active
  destination transport-method http
!
!
!
!
!
end

LISP3

version 17.3
service timestamps debug datetime msec
service timestamps log datetime msec
! Call-home is enabled by Smart-Licensing.
service call-home
platform qfp utilization monitor load 80
platform punt-keepalive disable-kernel-core
platform console serial
!
hostname LISP3
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!         
!
!
!
!
!
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
! 
! 
! 
! 
!
!         
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-3119736560
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3119736560
 revocation-check none
 rsakeypair TP-self-signed-3119736560
!
crypto pki trustpoint SLA-TrustPoint
 enrollment pkcs12
 revocation-check crl
!
!
crypto pki certificate chain TP-self-signed-3119736560
 certificate self-signed 01
  30820330 30820218 A0030201 02020101 300D0609 2A864886 F70D0101 05050030 
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274 
  69666963 6174652D 33313139 37333635 3630301E 170D3231 31303130 31363336 
  35315A17 0D333131 30313031 36333635 315A3031 312F302D 06035504 03132649 
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 31313937 
  33363536 30308201 22300D06 092A8648 86F70D01 01010500 0382010F 00308201 
  0A028201 0100C40A B68A6671 56175861 B63FF248 960BF6C5 20943E05 F22CDE0F 
  BADAB556 5F82064A 56D56332 D0E22FC3 AE7E3143 3AA4E495 D2A7DAF0 471A3A1C 
  E333F94D E60FB6FC F062DCB1 763FECEE 5DC26433 75AB6977 763EC8C5 C9DE4419 
  6A10D00D D1F85E6C 52B2A7A0 6025FD80 334F37F9 739170A1 50B51388 8ACAD89C 
  A9911653 C6800F7F B554ADD6 F8DC19E2 ED711DE2 5A65BEF6 288D4EC3 D35B425C 
  92A606E8 ECB08869 36A477A9 A32F5ED8 D7CC39B1 A60D3955 8D5AD0A3 F389895D 
  A2B2748A D03F47B2 DA8627EA 38FBD6B9 3D4F1C52 6E841D45 7A7C4E79 D24983C5 
  24E2C802 5E3CC5E6 56457F54 F33F448B 73E7771D 0F23565D 18F4EE05 EA52324D 
  F8959A51 01070203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 
  301F0603 551D2304 18301680 14AF537D C73ADF95 55749D2D CDA12AEA 977797F7 
  4B301D06 03551D0E 04160414 AF537DC7 3ADF9555 749D2DCD A12AEA97 7797F74B 
  300D0609 2A864886 F70D0101 05050003 82010100 82B30EDB 9DC69939 9EC523AA 
  71408F94 0CB5C350 612D6F72 636DC0B3 AC0B3660 7C229550 8B642C7B C09A8B90 
  34A6DB02 82ED2048 A80E1354 22E73353 3391AFE8 BDDCF00C A83A6CAF 691D6495 
  9647F357 8E799E5F 8BD31259 13DAF573 F88741EB 3B466E08 F3016E42 A402362D 
  A5E05CBF EC2F54EE 275D43F4 D028DFE1 305D3872 2EA34DD3 E88467AF FB672D30 
  755EDD19 14391E75 95111C44 8EA2FD61 3C8893F7 C74A46DF E1FEEDE2 95A2237B 
  00ECD375 466FED07 B71602B1 0DF02507 3BD8C656 5B181C0A 7143654F E7AAB94F 
  04E10992 77C7EF1F 928DFD11 05149CCF F0A24734 A4145566 295FE488 BEC4EEFD 
  7B89D712 79E18B50 030A0A95 7748EE0B 40D16E16
  quit
crypto pki certificate chain SLA-TrustPoint
 certificate ca 01
  30820321 30820209 A0030201 02020101 300D0609 2A864886 F70D0101 0B050030 
  32310E30 0C060355 040A1305 43697363 6F312030 1E060355 04031317 43697363 
  6F204C69 63656E73 696E6720 526F6F74 20434130 1E170D31 33303533 30313934 
  3834375A 170D3338 30353330 31393438 34375A30 32310E30 0C060355 040A1305 
  43697363 6F312030 1E060355 04031317 43697363 6F204C69 63656E73 696E6720 
  526F6F74 20434130 82012230 0D06092A 864886F7 0D010101 05000382 010F0030 
  82010A02 82010100 A6BCBD96 131E05F7 145EA72C 2CD686E6 17222EA1 F1EFF64D 
  CBB4C798 212AA147 C655D8D7 9471380D 8711441E 1AAF071A 9CAE6388 8A38E520 
  1C394D78 462EF239 C659F715 B98C0A59 5BBB5CBD 0CFEBEA3 700A8BF7 D8F256EE 
  4AA4E80D DB6FD1C9 60B1FD18 FFC69C96 6FA68957 A2617DE7 104FDC5F EA2956AC 
  7390A3EB 2B5436AD C847A2C5 DAB553EB 69A9A535 58E9F3E3 C0BD23CF 58BD7188 
  68E69491 20F320E7 948E71D7 AE3BCC84 F10684C7 4BC8E00F 539BA42B 42C68BB7 
  C7479096 B4CB2D62 EA2F505D C7B062A4 6811D95B E8250FC4 5D5D5FB8 8F27D191 
  C55F0D76 61F9A4CD 3D992327 A8BB03BD 4E6D7069 7CBADF8B DF5F4368 95135E44 
  DFC7C6CF 04DD7FD1 02030100 01A34230 40300E06 03551D0F 0101FF04 04030201 
  06300F06 03551D13 0101FF04 05300301 01FF301D 0603551D 0E041604 1449DC85 
  4B3D31E5 1B3E6A17 606AF333 3D3B4C73 E8300D06 092A8648 86F70D01 010B0500 
  03820101 00507F24 D3932A66 86025D9F E838AE5C 6D4DF6B0 49631C78 240DA905 
  604EDCDE FF4FED2B 77FC460E CD636FDB DD44681E 3A5673AB 9093D3B1 6C9E3D8B 
  D98987BF E40CBD9E 1AECA0C2 2189BB5C 8FA85686 CD98B646 5575B146 8DFC66A8 
  467A3DF4 4D565700 6ADF0F0D CF835015 3C04FF7C 21E878AC 11BA9CD2 55A9232C 
  7CA7B7E6 C1AF74F6 152E99B7 B1FCF9BB E973DE7F 5BDDEB86 C71E3B49 1765308B 
  5FB0DA06 B92AFE7F 494E8A9E 07B85737 F3A58BE1 1A48A229 C37C1E69 39F08678 
  80DDCD16 D6BACECA EEBC7CF9 8428787B 35202CDC 60E4616A B623CDBD 230E3AFB 
  418616A9 4093E049 4D10AB75 27E86F73 932E35B5 8862FDAE 0275156F 719BB2F0 
  D697DF7F 28
  quit
!
license udi pid CSR1000V sn 9HKSRSBJ1LY
diagnostic bootup level minimal
memory free low-watermark processor 71507
!
!
spanning-tree extend system-id
!
!
redundancy
!
!
!
!
!
!
!
! 
!
!
!
!
!
!
!
!
!
!
!
!         
!
! 
! 
!
!
interface Loopback1
 ip address 192.168.100.3 255.255.255.255
!
interface GigabitEthernet1
 ip address 10.0.3.1 255.255.255.0
 ip ospf 1 area 0
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet2
 ip address 192.168.3.254 255.255.255.0
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet3
 no ip address
 shutdown
 negotiation auto
 no mop enabled
 no mop sysid
!
interface GigabitEthernet4
 no ip address
 shutdown
 negotiation auto
 no mop enabled
 no mop sysid
!
router lisp
 locator-table default
 locator-set self
  IPv4-interface GigabitEthernet1 priority 0 weight 0
  exit-locator-set
 !
 service ipv4
  itr
  etr
  map-server
  map-resolver
  exit-service-ipv4
 !
 site LISP1
  description Site of LISP1
  authentication-key cisco
  eid-record 192.168.1.0/24
  eid-record 192.168.100.1/32
  allowed-locator 10.0.0.2
  exit-site
 !
 site LISP2
  description Site of LISP2
  authentication-key cisco
  eid-record 192.168.2.0/24
  eid-record 192.168.100.2/32
  allowed-locator 10.0.2.1
  exit-site
 !
 exit-router-lisp
!
router ospf 1
 passive-interface default
 no passive-interface GigabitEthernet1
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
line con 0
 stopbits 1
line vty 0 4
 login
 transport input ssh
!
call-home
 ! If contact email address in call-home is configured as sch-smart-licensing@cisco.com
 ! the email address configured in Cisco Smart License Portal will be used as contact email address to send SCH notifications.
 contact-email-addr sch-smart-licensing@cisco.com
 profile "CiscoTAC-1"
  active
  destination transport-method http
!
!
!
!
!
end

Posted

in

, ,

by

Tags:

Comments

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.