Categories
Mitel MiVoice VoIP

Mitel MiVoice Business: Understanding Class of Restriction

Class of restriction (COR) is an important feature on MiVoice controllers for protection and control over what calls can access an outgoing trunk group.

COR can be split into two parts, the class of restriction group themselves, and its members which are defined by an Class of Restriction number.

Confusion can occur since class of restriction group are also identified with a number, so it’s important to distinguish between a class of restriction group and a class of restriction number.

If a class of restriction number if part of a class of restriction group, the station associated with that number will not be able to access the outgoing route. To summarise, if a class of restriction is a member of a class of restriction group, it is blocked.

Classes of restriction can assigned to groups in the form System Properties > System Feature Settings > Class of Restriction Groups

Different parts of the system will utilise a class of restriction group to control its use, or can be assigned a class of restriction identifier to be used within groups.

Utilises a Class of Restriction Group

ARS Route (Blocks access to route)

ARS Leading Digits (Blocks access to a route as soon as leading digit is received)

Assigned a Class of Restriction Number

Station Attributes (COR assigned to individual phones)

Trunk Attributes (COR assigned to external trunks)

Use cases of class of restriction can include:

  • Stopping voicemail ports from dialing out of an external trunk
  • Only allowing international dialing for a select class of stations
  • Preventing an incoming trunk call from being able to dial out of another trunk
Categories
Mitel MiVoice VoIP

Capturing a SIP trace / PCAP on a Mitel Controller

Capturing a SIP trace can help in diagnosing issues with SIP communications on a Mitel controller.

Log into the System Administration Tool and and navigate to Maitenance and Diagnostics, Maintenance Commands.

In the command box, type SIP TCPDUMP ON

At this point, run any test calls that you need to capture into a PCAP file.

Once test calls have been completed, remember to to type SIP TCPDUMP OFF. If you don’t turn off the capture it will continue to fill up hard drive space on the Mitel controller.

Now open a FTP client and navigate to the IP address of the Mitel controller, use the same credentials you use to log into the web interface as the credentials to log in via FTP.

With the FTP connection established, navigate to the directory path /vmail – in this folder you will find the .pcap file containing a trace of all the calls made on the system during the capture window.

Happy troubleshooting!

Categories
Mikrotik VoIP

Connecting Power over Ethernet (PoE) Devices to Wireless

Typically in the average office there is ethernet ran to every desk providing a direct connection to whatever device may sit on the other end, including power to phones. With most people now working from home due to the pandemic ethernet may not be readily so available, so what can be done to provide a form of a connectivity to devices that need ethernet and power, such as a phone? If the user at least has 2.4Ghz wireless there is an easy solution: A Mikrotik and a suitable 48V power supply such as a PoE injector.

Mikrotik mAP 2nD. Image from mikrotik.com
48V power supply. Image from mikrotik.com

The Mikrotik mAP 2nD is a perfect device for a scenario where we may need a universal solution to power a phone at a desk with wireless connectivity to a home router. Accompanied with a power supply (or PoE injector) that can supply 48V, devices can be powered with its dedicated PoE port and provided network connectivity wireless using its built in 2.4Ghz wireless card.

The mAP 2nD can accept a range of power supply voltages ranging from 8 volts to 52 volts and pass it through via port ETH2 via Power over Ethernet. Most power over ethernet devices operate on 48V so a power supply of this voltage is required to power most devices out of the power over ethernet port.

It must be noted that the Mikrotik router does not come configured this way, and must be programmed to operate to bridge it’s wireless connection out of the ethernet port, a sample configuration is below:

/interface bridge
 add name=wireless2wired protocol-mode=none

/interface wireless security-profiles
add authentication-types=wpa2-psk mode=dynamic-keys name=bridgenetwork supplicant-identity=MikroTik wpa2-pre-shared-key=NetworkKey

/interface wireless
 set [ find default-name=wlan1 ] disabled=no frequency=auto mode=station-bridge security-profile=bridgenetwork ssid=NetworkName station-roaming=enabled wireless-protocol=802.11 wmm-support=enabled

/interface bridge port
add bridge=wireless2wired interface=wlan1
add bridge=wireless2wired interface=eth2

/ip dhcp-client
add disabled=no interface=wireless2wired

The configuration above will create a bridge to join two network interfaces together, the wireless network and the second ethernet port.

It basically allows any device plugged into the second ethernet port (ETH2) to communicate over the wireless network.

DHCP client will also be enabled on the bridge port to pick up an IP address on the local network to allow remote management.

If power over ethernet is not a requirement, and you’re just looking to connect a wired device to a wireless network, consider the mAP Lite.

The mAP Lite provides only a single ethernet port with no PoE out capabilities. Image from mikrotik.com

Categories
Mitel MiVoice VoIP

Poor ISDN call quality – Mitel / MiVoice 3300

We were tasked to look into a MiVoice Business controller in the UK that had been recently rebuilt from backup. Incoming or outgoing calls to the controller turned any calls into almost inaudiable noise.

Checking the ISDN forms against best practice it looked like nothing had been missed or mis-set, it was restored from a backup after all.

The key factor was eventually realised that this Mitel controller was freshly rebuilt with software reinstalled – the country was not set correctly! It was set to North America rather than United Kingdom.

The country setting of North America had messed with the codec/tones of the ISDN, so was producing the horrible noise on the phone line.

The Mitel controller during an out of hours window was set to United Kingdom in the country settings, system reset, and back-up restored.

The Mitel controller was back online, a call tested, perfectly clear audio.