Categories
Mikrotik VoIP

Connecting Power over Ethernet (PoE) Devices to Wireless

Typically in the average office there is ethernet ran to every desk providing a direct connection to whatever device may sit on the other end, including power to phones. With most people now working from home due to the pandemic ethernet may not be readily so available, so what can be done to provide a form of a connectivity to devices that need ethernet and power, such as a phone? If the user at least has 2.4Ghz wireless there is an easy solution: A Mikrotik and a suitable 48V power supply such as a PoE injector.

Mikrotik mAP 2nD. Image from mikrotik.com
48V power supply. Image from mikrotik.com

The Mikrotik mAP 2nD is a perfect device for a scenario where we may need a universal solution to power a phone at a desk with wireless connectivity to a home router. Accompanied with a power supply (or PoE injector) that can supply 48V, devices can be powered with its dedicated PoE port and provided network connectivity wireless using its built in 2.4Ghz wireless card.

The mAP 2nD can accept a range of power supply voltages ranging from 8 volts to 52 volts and pass it through via port ETH2 via Power over Ethernet. Most power over ethernet devices operate on 48V so a power supply of this voltage is required to power most devices out of the power over ethernet port.

It must be noted that the Mikrotik router does not come configured this way, and must be programmed to operate to bridge it’s wireless connection out of the ethernet port, a sample configuration is below:

/interface bridge
 add name=wireless2wired protocol-mode=none

/interface wireless security-profiles
add authentication-types=wpa2-psk mode=dynamic-keys name=bridgenetwork supplicant-identity=MikroTik wpa2-pre-shared-key=NetworkKey

/interface wireless
 set [ find default-name=wlan1 ] disabled=no frequency=auto mode=station-bridge security-profile=bridgenetwork ssid=NetworkName station-roaming=enabled wireless-protocol=802.11 wmm-support=enabled

/interface bridge port
add bridge=wireless2wired interface=wlan1
add bridge=wireless2wired interface=eth2

/ip dhcp-client
add disabled=no interface=wireless2wired

The configuration above will create a bridge to join two network interfaces together, the wireless network and the second ethernet port.

It basically allows any device plugged into the second ethernet port (ETH2) to communicate over the wireless network.

DHCP client will also be enabled on the bridge port to pick up an IP address on the local network to allow remote management.

If power over ethernet is not a requirement, and you’re just looking to connect a wired device to a wireless network, consider the mAP Lite.

The mAP Lite provides only a single ethernet port with no PoE out capabilities. Image from mikrotik.com

Categories
Mikrotik

UPNP for firewalled Mikrotiks

Universal Plug and Plug is a technology that can automatically open a port forward from your home router to a P.C.

This is an essential technology for the likes of home games consoles and Xbox Live to get that Open NAT setting; in a business enviroment I’d rather leave it disabled.

With firewall filter rules enabled on a Mikrotik UPNP is useless, unless you have one special rule:

add chain=forward connection-nat-state=dstnat in-interface=[inbound-interface]

This rule permits the connection through the firewall if it is to a port that is forwarded, even those through UPNP.

Make sure to place this rule in an appropriate place in case you are restricting access to any other ports!

Categories
Mikrotik

Mikrotik

2019 has been in a year where I’ve got to know an eastern european member of the routing and switching world – Mikrotik.

Founded in 1996 in Riga, Latvia, Mikrotik are widely popular in the wireless internet service provider world. Their routers have a huge offering of features in a very affordable package, you can pick up a router for less than £30 (hAP lite, here) with all the same software features as their most expensive offerings.

The difference in price comes with what hardware the software runs on. Mikrotik provide block diagrams on their website showing what the model number of specific hardware are capable of:

Block diagram of the hAP

The hAP for example, has wire speed switching on 10/100M ports, dual chain WAN, and a 650Mhz CPU speed.

Block diagram of the RB4011

If you compare that to the RB4011 on the higher end of the scale, you can clearly see what the extra premium in price is paying for: Two built in switches, 2.4Ghz and 5Ghz wireless, and a quard core 1.4Ghz processor.

I’ll say again though, the operating system that runs on both pieces of hardware is exactly the same. You can grab the configuration from one and pop it on the other with little or no configuration changes.

This operating system is called RouterOS, developed behind closed doors at Mikrotik HQ. It emulates many powerful features that would simply be too many to list here. Check out their well documented wiki to get a taste.

I hope to cover more on specific devices and tools on here soon, perhaps along with some common questions I see online.